ExpandableTab not working

Apr 13, 2011 at 7:11 PM

Hi,

I wanted to use the ExpandleTab for a project but I find it buggy. Actually I never got it work :)

As soon as the Panel is not in a ScrollViewer its not working.

I modified your sample to show you the problem.

<Grid x:Name="LayoutRoot" Background="White" Margin="10">
    <!--<ScrollViewer VerticalScrollBarVisibility="Auto">-->
        <StackPanel>
            <TextBlock FontSize="12" Text="ExpandableTab is a panel you can attach to a border of its container." TextWrapping="Wrap"/>
            <TextBlock FontSize="12" Text="You can expand it by clicking on the header." TextWrapping="Wrap"/>
            <Grid Margin="0,10,0,0">
                <!--<Border BorderBrush="Black" BorderThickness="1" Height="600">
                        </Border>-->
                <NopControls:ExpandableTab HeaderContent="Top Tab" HeaderHeight="30" HeaderWidth="100" Height="500" Width="400" HorizontalAlignment="Center" HeaderDockPosition="Top">
                    <Image Source="Images/01.jpg" Margin="6"/>
                </NopControls:ExpandableTab>
                <NopControls:ExpandableTab HeaderContent="Bottom Tab" HeaderHeight="30" HeaderWidth="100" Height="500" Width="400" ContainerBackground="Gray" ContainerBorderBrush="Black" Foreground="White" HorizontalAlignment="Center" HeaderDockPosition="Bottom">
                    <Image Source="Images/02.jpg" Margin="6"/>
                </NopControls:ExpandableTab>
                <NopControls:ExpandableTab HeaderContent="Left Tab - 1" HeaderHeight="30" HeaderWidth="80" Height="500" Width="400" VerticalAlignment="Center" HeaderDockPosition="Left" HeaderAlignment="Start">
                    <Image Source="Images/03.jpg" Margin="6"/>
                </NopControls:ExpandableTab>
                <NopControls:ExpandableTab HeaderContent="Left Tab - 2" HeaderHeight="30" HeaderWidth="80" Height="500" Width="400" VerticalAlignment="Center" HeaderDockPosition="Left" HeaderAlignment="Start" HeaderOffset="40">
                    <Image Source="Images/04.jpg" Margin="6"/>
                </NopControls:ExpandableTab>
                <NopControls:ExpandableTab HeaderContent="Left Tab - 3" HeaderHeight="30" HeaderWidth="80" Height="500" Width="400" VerticalAlignment="Center" HeaderDockPosition="Left" HeaderAlignment="Start" HeaderOffset="80">
                    <Image Source="Images/05.jpg" Margin="6"/>
                </NopControls:ExpandableTab>
                <NopControls:ExpandableTab HeaderHeight="60" HeaderWidth="70" Height="500" Width="400" VerticalAlignment="Center" HeaderDockPosition="Right">
                    <NopControls:ExpandableTab.HeaderContent>
                        <StackPanel Orientation="Vertical">
                            <Image Source="Images/06.jpg" Width="32" Height="32"/>
                            <TextBlock Text="Right Tab"/>
                        </StackPanel>
                    </NopControls:ExpandableTab.HeaderContent>
                    <Image Source="Images/04.jpg" Margin="6"/>
                </NopControls:ExpandableTab>
            </Grid>
        </StackPanel>
    <!--</ScrollViewer>-->
</Grid>

Nice work though.

Benjamin

Coordinator
Apr 15, 2011 at 1:58 AM

Ok...I will check wha's goinng wrong.

I will get back to you quickly

 

Coordinator
Apr 15, 2011 at 12:49 PM

Hi again,

after testing my last bits I didn't manage to reproduce the bug. Can you try using the last version in the source control?

 

Thanks.